FAQ on SlimFAQ
Menu

Supported Devices

Blast Baseball, Blast Softball, Blast Golf app Support for Apple Devices (unless otherwise noted) – Metrics & Video:

  • iPhone 6S, 6 Plus, 6S Plus, 7, 7 Plus, 8, 8 Plus, X, XR, Xs, Xs Max, 11, 11 Pro, 11 Pro Max
  • iPad Mini 3, iPad Mini 4, Air, Air 2, iPad 9.7″ (5th gen), iPad 9.7” (6th gen), iPad Pro 9.7″, iPad 10.2″ (7th gen), iPad Pro 10.5″ (2nd gen), iPad Pro 11″ (3rd gen), iPad Pro 12.9″ (2nd gen), iPad Pro 12.9” (3rd gen)
  • Compatible Apple devices must be running: iOS 11.x,12 .x, 13.x or later / iPad OS 13.x or later

Blast Baseball – Ball Flight Support for Apple Devices (iOS / iPad OS Only):

  • iPhone 7, 7 Plus, 8, 8 Plus, X, XR, XS, XS Max, 11, 11 Pro, 11 Pro Max
  • iPad 9.7″ (5th gen), iPad 9.7″ (6th gen), iPad 10.2 ” (7th gen), iPad Pro 10.5″ (2nd gen), iPad Pro 11″ (3rd gen), iPad Pro 12.9″ (2nd gen), iPad Pro 12.9” (3rd gen)
  • Compatible Apple devices must be running: iOS 11.x,12 .x, 13.x or later / iPad OS 13.x or later

Blast Vision App Support for Apple Devices (iOS / iPad OS Only):

  • iPhone 6S, 6S Plus, 7, 7 Plus, 8, 8 Plus, X, XR, XS, XS Max, 11, 11 Pro, 11 Pro Max
  • iPad 9.7″ (5th gen), iPad Pro 10.5″ (2nd gen), iPad Pro 11″ (3rd gen), iPad Pro 12.9″ (2nd gen), iPad Pro 12.9” (3rd gen)
  • Compatible Apple devices must be running: iOS 11.x,12 .x, 13.x or later / iPad OS 13.x or later

Blast Baseball, Blast Softball, Blast Golf App Support for Google Android Devices – Metrics & Video:

  • You can use the Blast app on all Android smartphones that meet the minimum system requirements. Please check out the Android system requirements and adaptive slow-mo requirements below for details
  • Android Tablets are not supported

Android System Requirements:

    • Android OS versions 7.0 (Nougat) and newer
    • Capacity: 32GB
    • Recording Quality: 1080p at 30 fps
    • Processor: 2.5Hz quad-core application processor

Adaptive Slow-Mo Requirements:

    • Only supported on: Galaxy S7 / S8 / S8+, Nexus 5x, Nexus 6P, Pixel, Pixel 3, Pixel XL

Any device that doesn’t meet the minimum specs may not be able to download the app and/or may experience degraded app performance. Click link for instructions on how to check system requirements on your device.

BodiTrak Dash App Support for Apple Devices (iOS only):

  • iPhone 6, 6S, 6 Plus, 6S Plus, 7, 7 Plus
  • iPad Mini 3, Air, Air 2, iPad Pro 9.7”
  • Compatible Apple devices must be running:  iOS 11.x or later

Languages Currently Supported: English

Measurement Units Supported: Imperial